import Foundation
let pattern = #"""
(?:[a-z0-9_-]+(?:\.[a-z0-9_-]+)*|"(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21\x23-\x5b\x5d-\x7f]|
\\[\x01-\x09\x0b\x0c\x0e-\x7f])*"){2,255}@(?:(?:[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,255}?\.)+[a-z0-9](?:[a-z0-9-]*[a-z0-9]){1,64}?|
\[(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?|[a-z0-9-]*[a-z0-9]:
(?:[\x01-\x08\x0b\x0c\x0e-\x1f\x21-\x5a\x53-\x7f]|\\[\x01-\x09\x0b\x0c\x0e-\x7f])+)\])
"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
valid.email@example.com
john.doe123@example.co.uk
alice_smith@company.org
user1234@emailprovider.net
test.email1234@email-domain.com
support@website.info
jane.doe@emailprovider.org
contact_us123@example.net
my.email123@email-provider.co
a@ce.ce
invalid.email@missingtld
john.doe@invaliddomain.c
spaces in@email.com
special!chars@email.com
noatemail.com
double..dots@email.com
@missingusername.com
user@inva@lid.com
missingatsigndomain.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}