import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]([+]\\d([-]\\d)?|[-]\\d([+]\\d)?)?$";
final String string = "a\n"
+ "a+1\n"
+ "a-2\n"
+ "a+3-4\n"
+ "a-5+6\n"
+ "a+1+2\n"
+ "a-3-4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}