const regex = new RegExp('^[a-z]([+]\\d([-]\\d)?|[-]\\d([+]\\d)?)?$', 'gm')
const str = `a
a+1
a-2
a+3-4
a-5+6
a+1+2
a-3-4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}