using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<scheme>.*?):\/\/(?<host>.*?)(?<path>\/[^?]*)|&?(?<name>[^\?]+?)=(?<value>[^&#]*)|#(?<fragment>.*)";
string input = @"https://pinaoffer.com/bazar?code=5kfU99TPUOyfr71lut94aSQw1pJn09&scaw=scafgaw&acdw=awcaw#jscasw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}