re = /^(?<scheme>.*?):\/\/(?<host>.*?)(?<path>\/[^?]*)|&?(?<name>[^\?]+?)=(?<value>[^&#]*)|#(?<fragment>.*)/m
str = 'https://pinaoffer.com/bazar?code=5kfU99TPUOyfr71lut94aSQw1pJn09&scaw=scafgaw&acdw=awcaw#jscasw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end