import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!(?<=pla)ng)(?!(?<=a)nlag)(?!(?<=i)nvest|nfo|nfra)(?!(?<=zuku)nft)nn?(?!finiti)[bcfgjklmpqrsvwxy](?!chaft|ormatio|eg(t|ung|e|s|itiv))";
final String string = "MATCH:\n\n"
+ "nonsense|waning|cannnnns|banger|fancy\n\n\n"
+ "NO MATCH:\n\n"
+ "plang|anlag|invest|warn|zukunft|design|mënsch|längt|telefo|termin|ioun|immun\n\n"
+ "plangens \n"
+ "pplang|clanlags|infrared|amazukunft\n\n"
+ "cannon|wand|hone|banana\n\n"
+ "BUT: Zukunftsunpassung (should match 'unpass' but not 'zukunft' and not 'ung')\n"
+ "Eegenschaftsunklang (should match 'Unkl' but not 'Eegenschaft' and not 'klang')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}