package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-z]{4,}s\b`)
var str = `hexes pixies major prairies caveman zipfiles oxes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}