package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([Ll]orem)[\s,.!:\-()?]+(ipsum)[\s,.!:\-()?]+(sit)[\s,.!:\-()?]+(amet)`)
var str = `Lorem ipsum, sit amet consectetur adipiscing elit. Lorem - ipsum, sit amet. Morbi a suscipit sem, quis finibus turpis. Lorem ipsum: sit amet. Proin suscipit ac arcu pharetra tincidunt. Lorem ipsum. sit amet. Pellentesque eu lacinia metus. sit amet: Lorem ipsum. Lorem turpis ipsum, sit amet.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}