re = /([Ll]orem)[\s,.!:\-()?]+(ipsum)[\s,.!:\-()?]+(sit)[\s,.!:\-()?]+(amet)/i
str = 'Lorem ipsum, sit amet consectetur adipiscing elit. Lorem - ipsum, sit amet. Morbi a suscipit sem, quis finibus turpis. Lorem ipsum: sit amet. Proin suscipit ac arcu pharetra tincidunt. Lorem ipsum. sit amet. Pellentesque eu lacinia metus. sit amet: Lorem ipsum. Lorem turpis ipsum, sit amet.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end