#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^#\r\n]+(?= #)"
Local $sString = "These are words before hashtag #work/abc/xyz/123" & @CRLF & _
"hi #bye" & @CRLF & _
" #tuesday" & @CRLF & _
"hello world" & @CRLF & _
"more testing #aaa" & @CRLF & _
"" & @CRLF & _
"one #two #three"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")