# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?P<hostname>Hostname:\s[^\n]+\n)
(?P<port>Port:\s[^\n]+\n+)
Misc\d:\s[\w\s]+\n+
(?P<management>Management\sAddress:
\s\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
)
(?:(?!^----)(?!^Model:).|\n)*
(?P<model>Model:\s[^\n]*)?
"""
test_str = ("--------------------\n"
"Hostname: Stuff\n"
"Port: g0/1\n\n"
"Misc1: lkbshjt7cy428\n\n"
"Management Address: 127.0.0.1\n\n"
"Misc2: aofigj46ujw\n"
"Misc3: 0193utjp9vu40-2\n\n"
"--------------------\n"
"Hostname: And\n"
"Port: g0/2\n\n"
"Misc1: g18u384gh89\n\n"
"Management Address: 127.0.0.2\n\n"
"Misc2: uhctpy9 24nmyhg894\n\n"
"--------------------\n"
"Hostname: Junk\n"
"Port: g0/3\n\n"
"Misc1: oit 2updhtg90234\n\n"
"Management Address: 127.0.0.3\n\n"
"Misc2: aohjq43p98u90u\n"
"Misc3: 92 ycn09874gy8o\n"
"Model: Thing\n"
"Misc4: 07vk378k3\n\n"
"--------------------")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.