re = /(?P<hostname>Hostname:\s[^\n]+\n)
(?P<port>Port:\s[^\n]+\n+)
Misc\d:\s[\w\s]+\n+
(?P<management>Management\sAddress:
\s\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
)
(?:(?!^----)(?!^Model:).|\n)*
(?P<model>Model:\s[^\n]*)?
/mx
str = '--------------------
Hostname: Stuff
Port: g0/1
Misc1: lkbshjt7cy428
Management Address: 127.0.0.1
Misc2: aofigj46ujw
Misc3: 0193utjp9vu40-2
--------------------
Hostname: And
Port: g0/2
Misc1: g18u384gh89
Management Address: 127.0.0.2
Misc2: uhctpy9 24nmyhg894
--------------------
Hostname: Junk
Port: g0/3
Misc1: oit 2updhtg90234
Management Address: 127.0.0.3
Misc2: aohjq43p98u90u
Misc3: 92 ycn09874gy8o
Model: Thing
Misc4: 07vk378k3
--------------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end