$re = '/^\w+(?:\.[gl]t)?$/m';
$str = 'anytext
anytext.gt
anytext.lt
anytext.xx
anytext.xx.gt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);