re = /^\w+(?:\.[gl]t)?$/m
str = 'anytext
anytext.gt
anytext.lt
anytext.xx
anytext.xx.gt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end