package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^stats\.gauges\.all\.cloudwatch\.communicationapi\.dynamodb\.(\w{2})_communicationapi_restaurantdispatchmethods\.(\w+)readcapacityunits\.maximum$`)
var str = `stats.gauges.all.cloudwatch.communicationapi.dynamodb.ca_communicationapi_restaurantdispatchmethods.provisionedreadcapacityunits.maximum
stats.gauges.all.cloudwatch.communicationapi.dynamodb.es_communicationapi_restaurantdispatchmethods.consumedreadcapacityunits.maximum
stats.gauges.all.cloudwatch.communicationapi.dynamodb.ca_communicationapi_restaurantdispatchmethods.provisionedreadcapacityunits.maximum`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}