use strict;
my $str = 'Very much a stupid beginner question, but trying to make a regex expression which would take in "5ms-1", "17km/h" or "9ms^-2" etc. with these ambiguous units and ambiguous formats. Please help, I can\'t manage it
5ms-1
17km/h
9ms^-2
-5mph
6.8m/h
+8liters/hectacre^2
5/h
1m^2s^2
this will also match the 21st century, 7eleven, 3M, and similar things.
';
my $regex = qr/(# the number at the beginning
[-+]? # optional leading sign
\d+# the digits to the left of the decimal
(?:\.\d+)? # an optional decimal amount
)
(#units
\/? #optional slash
[a-zA-Z]+ # must be alphabetic
(\^?[-+]?\d+(?:\.\d+)?)? # a caret followed by our same/initial digit pattern
)+/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}