re = /(# the number at the beginning
[-+]? # optional leading sign
\d+# the digits to the left of the decimal
(?:\.\d+)? # an optional decimal amount
)
(#units
\/? #optional slash
[a-zA-Z]+ # must be alphabetic
(\^?[-+]?\d+(?:\.\d+)?)? # a caret followed by our same\/initial digit pattern
)+/mx
str = 'Very much a stupid beginner question, but trying to make a regex expression which would take in "5ms-1", "17km/h" or "9ms^-2" etc. with these ambiguous units and ambiguous formats. Please help, I can\'t manage it
5ms-1
17km/h
9ms^-2
-5mph
6.8m/h
+8liters/hectacre^2
5/h
1m^2s^2
this will also match the 21st century, 7eleven, 3M, and similar things.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end