$re = '/^0*[1-9]\d{0,9}$/m';
$str = '12345
000001234567890
000000000012547
012345678900
12345678901
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);