re = /^0*[1-9]\d{0,9}$/m
str = '12345
000001234567890
000000000012547
012345678900
12345678901
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end