$re = '/(?<!UNLOAD \()(?<!UNLOAD\()\s*\'(.*?)\'\s*/m';
$str = 'it should match \'this\', not UNLOAD(\'this one\') or UNLOAD ( \'that one\' ), but match \'this one\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);