re = /(?<!UNLOAD \()(?<!UNLOAD\()\s*'(.*?)'\s*/m
str = 'it should match \'this\', not UNLOAD(\'this one\') or UNLOAD ( \'that one\' ), but match \'this one\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end