const regex = new RegExp('(?(DEFINE)
(?<tagName>
[a-z][a-z\\d]*+ (?=[>\\s/])
)
(?<tagAttr>
(?>
[^>"\\']++
| " [^"]*+ "
| \\' [^\\']*+ \\'
)*+
)
)
< (li|/ul) /?+ (?=[>\\s/]) ((?&tagAttr)) >
((?:
[^<]++
| < /?+ (?!(?:li|ul)(?=[>\\s/])) (?&tagName) (?&tagAttr) > #any tag except <li> and <ul>
| < (?! /?+ (?&tagName) ) #not tag
)*)
(?= < (?:li|/ul) (?=[>\\s/]) (?&tagAttr) ) #check for nested <li> and <ul>', 'gsiu')
const str = `<ul>
<li fhgfhfg ghgfhfghhfgh= ghghg="..." a = 'ghghg'>dfdsfsd
<ul>
<li>111</li>
<li/>2222
<li>mmmmm</li>
</ul>
<li>dfdsfdsfsdf <b class="..."><br/>fgdfgd<i></b><!-- dfdf--><li>
<li>
<li>dsfsdfsdfdsf
</ul>
`;
const subst = `<$3$4>$5</LI>\r`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);