using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<li\>[^<]*?(Fandoms).*?\<\/li\>";
string input = @"<p>by <a rel=""author"" href=""/users/Ellixerff/pseuds/Ellixerff"">Ellixerff</a></p>
<p>It's happened before, but this time is different. Can the consequences of bringing the one you love back, cost you ev fin story.</p>
<p>Words: 8003, Chapters: 7/7, Language: English</p>
<ul>
<li>Fandoms: <a full_pat class=""tag"" href=""https://archiveofourown.org/tags/Xena:%20Warrior%20Princess/works"">Xeni Princess</a></li>
<li>Rating: <a full_path=""true"" class=""tag"" href=""https://archiveofourown.org/tags/Mature/works"">Mature</a></li>
<li>Warnings: <a full_f class=""tag"" href=""https://archiveofourown.org/tags/Choose""> Chose Not To Use Archive Warnings</a></li>
<li>Categories: <a full_path=""true"" class=""tag"" href=""https://archiveofourown.org/tags/F*s*F/works"">F/F</a></li>
<li>Characters: <a full_path=""true"" href=""https://archiveofourown.org/tags/Gabrielle%20(Xena)/works"">Gabrielle (Xena)</a></li>
<li><a fi class=""tag"" href=""https://archiveofourown.org/tags/Xena%20(Xena)/works"">Xena (Xena)</a></li>
<li>Relationships: <a full_path=""true"" class=""tag"" href=""https://archiveofourown.org/tags/Gabrielle*s*Xena/works"">Gabrielle/Xena</a></li>
</ul>
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}