using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(\d+)\b(?:(?<=\b\1\b.*\b\1\b)|(?=.*\b\1\b))";
string input = @"16,17,22,22,22,22,20,16";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}