const regex = /\b(\d+)\b(?:(?<=\b\1\b.*\b\1\b)|(?=.*\b\1\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\d+)\\b(?:(?<=\\b\\1\\b.*\\b\\1\\b)|(?=.*\\b\\1\\b))', 'gm')
const str = `16,17,22,22,22,22,20,16`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}