package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*?\(.*?\).*$`)
var str = `A 123
B 456
Ab(123)
uV(a5afgsg3)
A 123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}