package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z0-9]+ )*[a-z0-9]+$`)
var str = `abcdefghij abcdefghij abcdefghij abcdefghij abcdef
abcdefghij abcdefghij abcdefghij abcdefghij abcdef
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljlj
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4&
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4
@$%
@$% #$%
a @#$% 2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}