// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^([a-z0-9]+ )*[a-z0-9]+$").unwrap();
let string = "abcdefghij abcdefghij abcdefghij abcdefghij abcdef
abcdefghij abcdefghij abcdefghij abcdefghij abcdef
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljlj
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4&
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4
@$%
@$% #$%
a @#$% 2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}