#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!(.+?\+){2,}|(.*?\-){2,})[a-z][\d+-]*"
Local $sString = "a" & @CRLF & _
"a+1" & @CRLF & _
"a-2" & @CRLF & _
"a+3-4" & @CRLF & _
"a-5+6" & @CRLF & _
"a+1+2" & @CRLF & _
"a-3-4" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")