re = /(?!(.+?\+){2,}|(.*?\-){2,})[a-z][\d+-]*/m
str = 'a
a+1
a-2
a+3-4
a-5+6
a+1+2
a-3-4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end