import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"(\\w+)\\\":[\\s]*\\\"([^\\,\\}\\\"]+)";
final String string = "{\"kind\":\"Event\",\"stage\":\"ResponseComplete\",\"requestURI\":\"/api/v1/namespaces/jej/endpoints/eji.com-aws-eji\",\"verb\":\"update\",\"user\":{\"username\":\"system:serviceaccount:efs:efs-provisioner\",\"uid\":\"ab5d27b4c-71a4f77323b0\",\"groups\":[\"system:serviceaccounts\",\"system:serviceaccounts:eji\",\"system:authenticated\"]},\"sourceIPs\":[\"10.0.0.0\"],\"userAgent\":\"eji-provisioner/v0.0.0 (linux/amd64) kubernetes/$Format\",\"objectRef\":{\"resource\":\"endpoints\",\"namespace\":\"edd\",\"name\":\"dds.com-aws-edds\",\"uid\":\"44ad8-899f-fbc1f4befb2f\",\"apiVersion\":\"v1\",\"resourceVersion\":\"8852157\"},\"responseStatus\":{\"metadata\":{},\"code\":200}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}