# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(\w+)\":[\s]*\"([^\,\}\"]+)"
test_str = "{\"kind\":\"Event\",\"stage\":\"ResponseComplete\",\"requestURI\":\"/api/v1/namespaces/jej/endpoints/eji.com-aws-eji\",\"verb\":\"update\",\"user\":{\"username\":\"system:serviceaccount:efs:efs-provisioner\",\"uid\":\"ab5d27b4c-71a4f77323b0\",\"groups\":[\"system:serviceaccounts\",\"system:serviceaccounts:eji\",\"system:authenticated\"]},\"sourceIPs\":[\"10.0.0.0\"],\"userAgent\":\"eji-provisioner/v0.0.0 (linux/amd64) kubernetes/$Format\",\"objectRef\":{\"resource\":\"endpoints\",\"namespace\":\"edd\",\"name\":\"dds.com-aws-edds\",\"uid\":\"44ad8-899f-fbc1f4befb2f\",\"apiVersion\":\"v1\",\"resourceVersion\":\"8852157\"},\"responseStatus\":{\"metadata\":{},\"code\":200}}"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.