import re
regex = re.compile(r"^\S+", flags=re.MULTILINE)
test_str = ("hstep3_num00 = a5;\n"
"hstep3_num01 = 3b;\n"
"hstep3_num02 = 4f;\n"
"hstep3_num03 = 27;\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")