re = /^\S+/m
str = 'hstep3_num00 = a5;
hstep3_num01 = 3b;
hstep3_num02 = 4f;
hstep3_num03 = 27;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end