const regex = /\[([^][]+)]\((?![^()]*\bnotes\.md\b)[^()]*\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^][]+)]\\((?![^()]*\\bnotes\\.md\\b)[^()]*\\)', 'gm')
const str = `[Item 1](./path/notes.md)
[Item 2](./path)
[Item 3](./path/notes.md)
[Item 4](./path)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}