$re = '/\[([^][]+)]\((?![^()]*\bnotes\.md\b)[^()]*\)/m';
$str = '[Item 1](./path/notes.md)
[Item 2](./path)
[Item 3](./path/notes.md)
[Item 4](./path)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);