re = /\(\"([^\"]*)\"\)/
str = 'jh2kn as.12an sss g2gs.Abc("xxx")asdf;njkasahsda ng2gs.Abc("yyy")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end