# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b((?:ri)?comprat)[aeio]\b/\1+/gm;t' <<< "ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati"