import re
regex = re.compile(r"\b((?:ri)?comprat)[aeio]\b", flags=re.MULTILINE)
test_str = "ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati"
subst = "\\1+"
result = regex.sub(subst, test_str)
if result:
print(result)