use strict;
my $str = 'abc18.Dat wy.03/12/2019FFF*Dato dost2009/03/03**data wy2020-09-30';
my $regex = qr~dat(?:(?!dat).)*?wy.*?(\d{1,4}([\/ .-])\d{1,2}\2\d{1,4})~mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}