package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<v1>.+:\\.+?\\(.+?)\\.+)`)
var str = `c:\ABC\DEF\LOGS\1.LOG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}