package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<score>\d+)(?: (?P<note>[^,]+))?`)
var str = `20 M B, 25, 21
40, 43, 45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}