$re = '/(?P<score>\d+)(?: (?P<note>[^,]+))?/m';
$str = '20 M B, 25, 21
40, 43, 45';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);