package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\d{5}[A-Z])+$`)
var str = `12345t12345u
12345t12345u12345h12345u`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}