$re = '/^(?:\d{5}[A-Z])+$/mi';
$str = '12345t12345u
12345t12345u12345h12345u';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);