#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=https:\/\/www\.ducati\.com\/es\/es\/motocicletas\/)[a-z].+(?=\/)"
Local $sString = "https://www.ducati.com/es/es/motocicletas/monster/monster-797" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/diavel/diavel-1260" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard-950" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200-25-anniversario" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200r" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/monster/monster-797" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/monster/monster-821" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260-enduro" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-950" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-enduro" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/panigale/1299-panigale-r-final-edition" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/panigale/959-panigale" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4-r" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/supersport/supersport" & @CRLF & _
"https://www.ducati.com/es/es/motocicletas/xdiavel/xdiavel"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")