import re
regex = re.compile(r"(?<=https:\/\/www\.ducati\.com\/es\/es\/motocicletas\/)[a-z].+(?=\/)", flags=re.MULTILINE)
test_str = ("https://www.ducati.com/es/es/motocicletas/monster/monster-797\n"
"https://www.ducati.com/es/es/motocicletas/diavel/diavel-1260\n"
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard\n"
"https://www.ducati.com/es/es/motocicletas/hypermotard/hypermotard-950\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200-25-anniversario\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-1200r\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-797\n"
"https://www.ducati.com/es/es/motocicletas/monster/monster-821\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-1260-enduro\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-950\n"
"https://www.ducati.com/es/es/motocicletas/multistrada/multistrada-enduro\n"
"https://www.ducati.com/es/es/motocicletas/panigale/1299-panigale-r-final-edition\n"
"https://www.ducati.com/es/es/motocicletas/panigale/959-panigale\n"
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4\n"
"https://www.ducati.com/es/es/motocicletas/panigale/panigale-v4-r\n"
"https://www.ducati.com/es/es/motocicletas/supersport/supersport\n"
"https://www.ducati.com/es/es/motocicletas/xdiavel/xdiavel")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")