$re = '/[ ]*(?:[/-][ ]*)?#(?![^#\n\r]*#)[\da-zA-Z. -]+/m';
$str = '1-Some String #0123
2-Some String #1234-56-a
3-Some String #1234-56A
4-Some String (Fubar/ #12-345-67A)
5-Some String (Fubar - #12-345.67 A)
6-Some String / #123
7-Some String/#0233
8-Some #1 String/#0233';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;