import Foundation
let pattern = ##"[ ]*(?:[/-][ ]*)?#(?![^#\n\r]*#)[\da-zA-Z. -]+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
1-Some String #0123
2-Some String #1234-56-a
3-Some String #1234-56A
4-Some String (Fubar/ #12-345-67A)
5-Some String (Fubar - #12-345.67 A)
6-Some String / #123
7-Some String/#0233
8-Some #1 String/#0233
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)