#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\.]*\.(?<All>.*)"
Local $sString = " TMS_KEP.Male_RTU2.Male_PRM1_GL_OUT" & @CRLF & _
" TMS_KEP.Male_RTU2.Male_PRM1_PS_IN" & @CRLF & _
" TMS_KEP.Female_RTU2.Female_WC8_RL_OUT" & @CRLF & _
" TMS_KEP.Male_RTU1.Male_WC3_FS_OUT" & @CRLF & _
" TMS_KEP.Male_RTU1.Male_WC5_FS_OUT" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")